Problems with Thief and Deus Ex 2

Huddy

New Member
Registered
Jun 23, 2005
194
0
0
45
The Boiler Room
#1
Ok, I consider my system fairly good. It's a 2.4 GHz Pentium 4, a ATI Radeon 9700 Pro, tons of hard drive space, 1GB of Corsair RAM.
I can play Far Cry at a nice clip, and Doom 3 has no problem what so ever (at 800x600). But I cannot for the life of me, even with all the options set at the lowest, get Thief: Deadly Shadows and Deus Ex: Invisible War to run faster than a few frames a second. They're both highly unplayable.
Any recommendations, or ini tweaks anyone knows of to help?
 

ActionHank

Staff Writer (PC, Xbox)
Registered
Jun 23, 2005
548
0
0
33
Nashville
www.kat5kaos.com
#2
I dont know what that is but thats just game compatability....make sure you have the latest drivers for everything on your computer and make sure your game is patched all the way up. See if there is a fourm or something that talks about this problem.
 

Huddy

New Member
Registered
Jun 23, 2005
194
0
0
45
The Boiler Room
#3
All my drivers, etc are updated, and I religiously do so. I know it's been a known fact that Deux Ex doesn't run that well, and wasn't optimized to the best of it's capability anyway, but I still just wondered if there were some ini tweaks much like the ones to make Doom 3 patter along at a better pace.
 

Jasconius

New Member
Registered
Jun 23, 2005
78
0
0
Tampa Bay
#4
Are you running them in OpenGL?

Radeon cards do not handle openGL very well at all, and that could be the cause of your crapiness. Try setting it to D3D. If there is no option to set the video language, then you may have a different problem at hand.